User Tools

Site Tools


products:ict:communications:courses:cisco:ccna:configuring_inter_vlan_routing_using_router_on_a_stick_method

Certainly! Router-on-a-Stick is a technique used to enable inter-VLAN routing using a single physical link between a router and a switch. Let's walk through the steps to configure it:

1. Create VLANs on the Switch (S1):

  1. Create VLAN 10 and VLAN 30 on S1:

```

      S1(config)# vlan 10
      S1(config-vlan)# name LAN10
      S1(config-vlan)# exit
      S1(config)# vlan 30
      S1(config-vlan)# name LAN30
      S1(config-vlan)# exit
      ```

2. Assign VLANs to Ports:

  1. Configure interfaces F0/6 and F0/11 as access ports and assign VLANs:

```

      S1(config)# interface f0/11
      S1(config-if)# switchport mode access
      S1(config-if)# switchport access vlan 10
      S1(config-if)# interface f0/6
      S1(config-if)# switchport mode access
      S1(config-if)# switchport access vlan 30
      ```

3. Test Connectivity:

  1. Verify that PC1 and PC3 can ping each other. If not, remember that they are on different IP networks and require a router or Layer 3 switch for communication.

4. Configure Subinterfaces on R1 (Router):

  1. Create subinterfaces on R1 using 802.1Q encapsulation:

```

      R1(config)# interface g0/0.10
      R1(config-subif)# encapsulation dot1Q 10
      R1(config-subif)# ip address 172.17.10.1 255.255.255.0
      R1(config-subif)# interface g0/0.30
      R1(config-subif)# encapsulation dot1Q 30
      R1(config-subif)# ip address 172.17.30.1 255.255.255.0
      ```

5. Verify Configuration:

  1. Use the `show ip interface brief` command to verify subinterface configuration.

Remember that router-on-a-stick allows routing between VLANs by logically dividing the router interface into subinterfaces, each associated with a specific VLAN. Trunk links between switches and the router are essential for forwarding traffic within and between VLANs. ๐ŸŒ๐Ÿ”—

![Router-on-a-Stick Topology](https://www.ciscopress.com/articles/article.asp?p=3089357&seqNum=5)

products/ict/communications/courses/cisco/ccna/configuring_inter_vlan_routing_using_router_on_a_stick_method.txt ยท Last modified: 2024/04/01 03:20 by wikiadmin